iftop-1.0_pre4.ebuild 878 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="display bandwidth usage on an interface"
  6. SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
  7. HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND="
  13. net-libs/libpcap
  14. sys-libs/ncurses:0="
  15. DEPEND="
  16. ${RDEPEND}
  17. virtual/pkgconfig
  18. "
  19. S="${WORKDIR}"/${P/_/}
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${P}-tinfo.patch
  22. # bug 490168
  23. cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
  24. epatch "${FILESDIR}"/${P}-pthread.patch
  25. eautoreconf
  26. }
  27. src_install() {
  28. dosbin iftop
  29. doman iftop.8
  30. dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
  31. }