postal-0.72.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="SMTP and POP mailserver benchmark. Supports SSL, randomized user accounts and more"
  6. HOMEPAGE="http://www.coker.com.au/postal/"
  7. SRC_URI="http://www.coker.com.au/postal/${P}.tgz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
  11. IUSE="ssl gnutls"
  12. #ssl is an alias for openssl. If both ssl and gnutls are enabled, automagic will
  13. #enable only gnutls.
  14. DEPEND="ssl? (
  15. !gnutls? ( >=dev-libs/openssl-0.9.8g )
  16. gnutls? ( >=net-libs/gnutls-2.2.2 )
  17. )"
  18. RDEPEND="${DEPEND}"
  19. src_prepare() {
  20. epatch "${FILESDIR}/01_${PN}-0.70-gcc43.patch"
  21. epatch "${FILESDIR}/02_${PN}-0.72-nossl.patch"
  22. epatch "${FILESDIR}/03_${PN}-0.70-c++0x-integrated.patch"
  23. epatch "${FILESDIR}/04_${PN}-0.70-warnings.patch"
  24. epatch "${FILESDIR}/05_${PN}-0.70-openssl-1.patch"
  25. epatch "${FILESDIR}/06_${PN}-0.70-ldflags.patch"
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf \
  30. --disable-stripping \
  31. $(use_enable ssl openssl) \
  32. $(use_enable gnutls)
  33. }