sec-2.7.11.ebuild 588 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Simple Event Correlator"
  5. HOMEPAGE="https://github.com/simple-evcorr/sec"
  6. SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
  10. RDEPEND=">=dev-lang/perl-5.8.0"
  11. src_install() {
  12. dobin sec
  13. dodoc ChangeLog README
  14. docinto contrib
  15. dodoc contrib/{itostream.c,convert.pl,swatch2sec.pl}
  16. newman sec.man sec.1
  17. newinitd "${FILESDIR}"/sec.init.d sec
  18. newconfd "${FILESDIR}"/sec.conf.d sec
  19. }