dshieldpy-3.2-r2.ebuild 612 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Python script to submit firewall logs to dshield.org"
  7. HOMEPAGE="http://dshieldpy.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/dshieldpy/${P}.tar.gz"
  9. IUSE=""
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc x86"
  13. DEPEND="${PYTHON_DEPEND}"
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}/DShield.py"
  16. src_prepare() {
  17. default
  18. python_fix_shebang dshield.py
  19. }
  20. src_install() {
  21. default
  22. dobin dshield.py
  23. insinto /etc
  24. doins dshieldpy.conf
  25. }