s3fs-1.80.ebuild 975 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. MY_PN=${PN}-fuse
  6. MY_P=${MY_PN}-${PV}
  7. DESCRIPTION="Amazon S3 mounting via fuse"
  8. HOMEPAGE="https://github.com/s3fs-fuse/s3fs-fuse/"
  9. SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-2+"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE="openssl nss gnutls nettle"
  14. REQUIRED_USE="
  15. ^^ ( openssl nss gnutls )
  16. nettle? ( gnutls )"
  17. CDEPEND="
  18. >=dev-libs/libxml2-2.6:2
  19. openssl? ( dev-libs/openssl:0 )
  20. nss? ( dev-libs/nss )
  21. gnutls? ( net-libs/gnutls )
  22. nettle? ( dev-libs/nettle )
  23. >=net-misc/curl-7.0
  24. >=sys-fs/fuse-2.8.4"
  25. RDEPEND="
  26. ${CDEPEND}
  27. app-misc/mime-types"
  28. DEPEND="
  29. ${CDEPEND}
  30. virtual/pkgconfig"
  31. RESTRICT="test"
  32. S="${WORKDIR}/${MY_P}"
  33. src_prepare() {
  34. default
  35. eautoreconf
  36. }
  37. src_configure() {
  38. econf \
  39. $(use_with nss) \
  40. $(use_with nettle) \
  41. $(use_with gnutls) \
  42. $(use_with openssl)
  43. }