libmnl-1.0.3-r1.ebuild 733 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Minimalistic netlink library"
  6. HOMEPAGE="http://netfilter.org/projects/libmnl"
  7. SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux"
  11. IUSE="examples static-libs"
  12. src_configure() {
  13. econf $(use_enable static-libs static)
  14. }
  15. src_install() {
  16. default
  17. gen_usr_ldscript -a mnl
  18. prune_libtool_files
  19. if use examples; then
  20. find examples/ -name 'Makefile*' -delete
  21. dodoc -r examples/
  22. docompress -x /usr/share/doc/${PF}/examples
  23. fi
  24. }