1234567891011121314151617181920212223242526272829303132 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=4
- inherit eutils toolchain-funcs
- DESCRIPTION="Minimalistic netlink library"
- HOMEPAGE="http://netfilter.org/projects/libmnl"
- SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
- LICENSE="LGPL-2.1"
- SLOT="0"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux"
- IUSE="examples static-libs"
- src_configure() {
- econf $(use_enable static-libs static)
- }
- src_install() {
- default
- gen_usr_ldscript -a mnl
- prune_libtool_files
- if use examples; then
- find examples/ -name 'Makefile*' -delete
- dodoc -r examples/
- docompress -x /usr/share/doc/${PF}/examples
- fi
- }
|