liboping-1.8.0.ebuild 821 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit base autotools
  5. DESCRIPTION="C library and ncurses based program to generate ICMP echo requests and ping multiple hosts at once"
  6. HOMEPAGE="http://noping.cc/"
  7. SRC_URI="http://noping.cc/files/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1 GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. IUSE="perl"
  12. DEPEND="
  13. sys-libs/ncurses
  14. perl? ( dev-lang/perl )
  15. "
  16. RDEPEND=${DEPEND}
  17. PATCHES=( "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch" )
  18. src_prepare() {
  19. base_src_prepare
  20. eautoreconf
  21. }
  22. src_configure() {
  23. econf \
  24. $(use_with perl perl-bindings INSTALLDIRS=vendor) \
  25. --disable-static
  26. }
  27. src_install() {
  28. default
  29. find "${D}" -name '*.la' -delete || die
  30. fperms u+s,og-r /usr/bin/oping
  31. fperms u+s,og-r /usr/bin/noping
  32. }