libpri-1.4.14.ebuild 676 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit base
  5. MY_P="${P/_/-}"
  6. S="${WORKDIR}/${MY_P}"
  7. DESCRIPTION="Primary Rate ISDN (PRI) library"
  8. HOMEPAGE="http://www.asterisk.org/"
  9. SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. KEYWORDS="~amd64 ~sparc ~x86"
  13. IUSE=""
  14. PATCHES=(
  15. "${FILESDIR}/${PN}-1.4.13-multilib.patch"
  16. "${FILESDIR}/${PN}-1.4.13-respect-user-flags.patch"
  17. "${FILESDIR}/${PN}-1.4.13-no-static-lib.patch"
  18. )
  19. src_install() {
  20. emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install
  21. dodoc ChangeLog README TODO
  22. }