libtelnet-9999.ebuild 761 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils autotools
  5. DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
  6. HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
  7. if [ ${PV} = 9999 ]; then
  8. KEYWORDS=""
  9. EGIT_REPO_URI="https://github.com/seanmiddleditch/${PN}.git"
  10. inherit git-2
  11. DEPEND="dev-vcs/git"
  12. S="${WORKDIR}/${PN}-master"
  13. else
  14. KEYWORDS="~x86 ~amd64"
  15. SRC_URI="https://github.com/seanmiddleditch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  16. fi
  17. WANT_AUTOMAKE=1.11
  18. DEPEND="${DEPEND} sys-devel/automake:${WANT_AUTOMAKE}"
  19. LICENSE="public-domain"
  20. SLOT="0"
  21. IUSE=""
  22. RDEPEND=""
  23. src_prepare() {
  24. _elibtoolize
  25. eaclocal
  26. eautoconf
  27. eautoheader
  28. eautomake
  29. }