loudmouth-1.5.2-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Lightweight C Jabber library"
  6. HOMEPAGE="https://github.com/mcabber/loudmouth"
  7. SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. #SRC_URI="https://mcabber.com/files/${PN}/${P}.tar.bz2"
  9. LICENSE="LGPL-2.1"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
  12. IUSE="asyncns ssl openssl static-libs test"
  13. # Automagic libidn dependency
  14. RDEPEND="
  15. >=dev-libs/glib-2.16:2
  16. net-dns/libidn
  17. ssl? (
  18. !openssl? ( >=net-libs/gnutls-1.4.0 )
  19. openssl? ( dev-libs/openssl:0 )
  20. )
  21. asyncns? ( >=net-libs/libasyncns-0.3 )
  22. "
  23. DEPEND="${RDEPEND}
  24. test? ( dev-libs/check )
  25. virtual/pkgconfig
  26. >=dev-util/gtk-doc-1
  27. >=dev-util/gtk-doc-am-1
  28. "
  29. src_prepare() {
  30. eautoreconf
  31. }
  32. src_configure() {
  33. local myconf
  34. if use ssl; then
  35. if ! use openssl; then
  36. myconf="${myconf} --with-ssl=gnutls"
  37. else
  38. myconf="${myconf} --with-ssl=openssl"
  39. fi
  40. else
  41. myconf="${myconf} --with-ssl=no"
  42. fi
  43. econf \
  44. $(use_enable static-libs static) \
  45. $(use_with asyncns) \
  46. ${myconf}
  47. }