astmanproxy-1.28.2.ebuild 970 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit base multilib toolchain-funcs
  5. DESCRIPTION="Proxy for the Asterisk manager interface"
  6. HOMEPAGE="https://github.com/davies147/astmanproxy/"
  7. SRC_URI="https://github.com/davies147/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. IUSE=""
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. DEPEND=""
  13. PATCHES=( "${FILESDIR}/${P}-gentoo.diff" )
  14. src_prepare() {
  15. base_src_prepare
  16. # Fix multilib
  17. sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" "${S}/Makefile" \
  18. || die "multilib sed failed"
  19. }
  20. src_compile() {
  21. emake CC="$(tc-getCC)" \
  22. LDFLAGS="${LDFLAGS}" \
  23. LD="$(tc-getLD)" \
  24. RAWLDFLAGS="$(raw-ldflags)"
  25. }
  26. src_install() {
  27. dosbin astmanproxy
  28. dodoc README VERSIONS
  29. docinto samples
  30. dodoc samples/*
  31. insinto /etc/asterisk
  32. doins configs/astmanproxy.conf
  33. doins configs/astmanproxy.users
  34. newinitd "${FILESDIR}"/astmanproxy.rc6 astmanproxy
  35. }