batctl-2014.2.0.ebuild 860 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit linux-info toolchain-funcs
  5. DESCRIPTION="BATMAN advanced control and management tool"
  6. HOMEPAGE="http://www.open-mesh.org/"
  7. SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="dev-libs/libnl:3"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. pkg_setup() {
  16. if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
  17. || ! has_version net-misc/batman-adv ; then
  18. ewarn "You need the batman-adv kernel module,"
  19. ewarn "either from the kernel tree or via net-misc/batman-adv"
  20. fi
  21. }
  22. src_compile() {
  23. emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
  27. dodoc README
  28. }