htpdate-1.0.7.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit readme.gentoo toolchain-funcs unpacker
  5. DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
  6. HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
  7. SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ~ppc64 s390 sh x86 ~amd64-linux ~x86-linux"
  11. DEPEND=""
  12. RDEPEND=""
  13. DOC_CONTENTS="If you would like to run htpdate as a daemon, set
  14. appropriate http servers in /etc/conf.d/htpdate!"
  15. src_unpack() {
  16. default
  17. cd "${S}" || die "change directory to ${S} failed"
  18. unpacker htpdate.8.gz
  19. }
  20. src_prepare() {
  21. # Use more standard adjtimex() to fix uClibc builds.
  22. sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
  23. }
  24. src_compile() {
  25. emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
  26. }
  27. src_install() {
  28. dosbin htpdate
  29. doman htpdate.8
  30. dodoc README Changelog
  31. newconfd "${FILESDIR}"/htpdate.conf htpdate
  32. newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
  33. readme.gentoo_create_doc
  34. }