htpdate-1.1.2.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit readme.gentoo toolchain-funcs unpacker
  5. DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
  6. HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
  7. SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux"
  11. DEPEND=""
  12. RDEPEND=""
  13. DOC_CONTENTS="If you would like to run htpdate as a daemon, set
  14. appropriate http servers in /etc/conf.d/htpdate!"
  15. src_prepare() {
  16. # Use more standard adjtimex() to fix uClibc builds.
  17. sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
  18. }
  19. src_compile() {
  20. emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
  21. }
  22. src_install() {
  23. dosbin htpdate
  24. doman htpdate.8
  25. dodoc README Changelog
  26. newconfd "${FILESDIR}"/htpdate.conf htpdate
  27. newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
  28. readme.gentoo_create_doc
  29. }