liveice-2000530-r1.ebuild 805 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Live Source Client For IceCast"
  6. HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
  7. SRC_URI="http://star.arm.ac.uk/~spm/software/liveice.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 x86"
  11. IUSE=""
  12. RDEPEND="media-sound/lame
  13. media-sound/mpg123"
  14. DEPEND=""
  15. S=${WORKDIR}/${PN}
  16. src_prepare() {
  17. # cannot use LDFLAGS directly as the Makefile uses it for LIBS
  18. sed -i Makefile.in \
  19. -e 's|-o liveice|$(LLFLAGS) &|' \
  20. || die "sed Makefile.in"
  21. tc-export CC
  22. }
  23. src_compile() {
  24. emake LLFLAGS="${LDFLAGS}" || die
  25. }
  26. src_install() {
  27. dobin liveice || die
  28. dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
  29. }