secpanel-0.6.1-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. DESCRIPTION="Graphical frontend for managing and running SSH and SCP connections"
  5. HOMEPAGE="http://themediahost.de/secpanel/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 sparc x86"
  10. IUSE="gif"
  11. DEPEND="!gif? ( virtual/imagemagick-tools )"
  12. RDEPEND="virtual/ssh dev-lang/tk"
  13. S=${WORKDIR}/usr/local
  14. src_prepare() {
  15. # install arch indep stuff in /usr/share instead of /usr/lib*
  16. sed -i -e '/set libdir/s:../lib:../share:' bin/secpanel || die
  17. # fix the version
  18. sed -i -e "/set spversion/s:0.6.0:${PV}:" bin/secpanel || die
  19. # optionally remove gifs...
  20. if ! use gif; then
  21. einfo "Setting secpanel to use PPM images"
  22. sed -i -e 's/\.gif/\.ppm/g' bin/secpanel || die
  23. einfo "Converting all GIF images to PPM format..."
  24. for i in $(find lib/secpanel/images -name "*.gif") ; do
  25. einfo "convert ${i} => ${i//.gif/.ppm}"
  26. convert "${i}" "ppm:${i//.gif/.ppm}" || die
  27. rm -v "${i}" || die
  28. done
  29. fi
  30. }
  31. src_install() {
  32. dobin bin/secpanel || die
  33. insinto /usr/share/secpanel
  34. doins -r lib/secpanel/{*.{tcl,config,profile,wait,txt,sh},images,spdistkey} || die
  35. }