usbip-3.19.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ETYPE="sources"
  5. K_NOUSENAME=1
  6. inherit autotools eutils kernel-2
  7. DESCRIPTION="Userspace utilities for a general USB device sharing system over IP networks"
  8. HOMEPAGE="https://www.kernel.org/"
  9. SRC_URI="${KERNEL_URI}"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="static-libs tcpd"
  14. RESTRICT=""
  15. RDEPEND=">=dev-libs/glib-2.6
  16. sys-apps/hwids
  17. >=sys-kernel/linux-headers-3.17
  18. virtual/libudev
  19. tcpd? ( sys-apps/tcp-wrappers )"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. DOCS="AUTHORS README ../../../drivers/usb/usbip/usbip_protocol.txt"
  23. S=${WORKDIR}/linux-${PV}/tools/usb/${PN}
  24. src_prepare() {
  25. # remove -Werror from build, bug #545398
  26. sed -i 's/-Werror[^ ]* //g' configure.ac || die
  27. eautoreconf
  28. }
  29. src_configure() {
  30. econf \
  31. $(use_enable static-libs static) \
  32. $(use tcpd || echo --without-tcp-wrappers) \
  33. --with-usbids-dir=/usr/share/misc
  34. }
  35. src_install() {
  36. default
  37. prune_libtool_files
  38. }
  39. pkg_postinst() {
  40. elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
  41. elog "machine's kernel config and USBIP_HOST on the server."
  42. }