nsscache-0.30.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils distutils-r1
  6. DESCRIPTION="commandline tool to sync directory services to local cache"
  7. HOMEPAGE="https://github.com/google/nsscache"
  8. SRC_URI="https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  13. IUSE="nssdb nsscache"
  14. DEPEND="${PYTHON_DEPS}
  15. dev-python/python-ldap[${PYTHON_USEDEP}]
  16. dev-python/pycurl[${PYTHON_USEDEP}]
  17. nssdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )"
  18. RDEPEND="${DEPEND}
  19. nssdb? ( sys-libs/nss-db )
  20. nsscache? ( >=sys-auth/libnss-cache-0.10 )"
  21. RESTRICT="test"
  22. S="${WORKDIR}/${PN}-version-${PV}"
  23. src_prepare() {
  24. find "${S}" -name '*.py' -exec \
  25. sed -i '/^import bsddb$/s,bsddb,bsddb3 as bsddb,g' \
  26. {} \+
  27. distutils-r1_src_prepare
  28. }
  29. src_install() {
  30. distutils-r1_src_install
  31. doman nsscache.1 nsscache.conf.5
  32. dodoc THANKS nsscache.cron
  33. keepdir /var/lib/nsscache
  34. }