bladerf-firmware-2.0.0.ebuild 805 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="bladeRF FX3 firmware images"
  5. HOMEPAGE="http://nuand.com/fx3.php"
  6. #firmware is open source, but uses a proprietary toolchain to build
  7. #automated builds from git are available, but likely unneeded
  8. #http://hoopycat.com/bladerf_builds/
  9. SRC_URI="http://nuand.com/fx3/bladeRF_fw_v${PV}.img"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~arm ~x86"
  13. IUSE=""
  14. DEPEND=""
  15. RDEPEND="${DEPEND}"
  16. S="${DISTDIR}"
  17. src_install() {
  18. insinto /usr/share/Nuand/bladeRF/
  19. doins bladeRF_fw_v${PV}.img
  20. }
  21. pkg_postinst() {
  22. elog "Please remember you have to actually flash this onto"
  23. elog "your bladerf with the following command:"
  24. elog "bladeRF-cli -f /usr/share/Nuand/bladeRF/bladeRF_fw_v${PV}.img"
  25. }