chirp-20170309.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. if [[ ${PV} == "99999999" ]] ; then
  6. SCM=mercurial
  7. EHG_REPO_URI="http://d-rats.com/hg/chirp.hg"
  8. fi
  9. inherit distutils-r1 ${SCM}
  10. DESCRIPTION="Free open-source tool for programming your amateur radio"
  11. HOMEPAGE="http://chirp.danplanet.com"
  12. if [[ ${PV} == "99999999" ]] ; then
  13. KEYWORDS=""
  14. else
  15. KEYWORDS="~amd64 ~x86"
  16. SRC_URI="http://trac.${PN}.danplanet.com/${PN}_daily/daily-${PV}/${PN}-daily-${PV}.tar.gz"
  17. S="${WORKDIR}/${PN}-daily-${PV}"
  18. RESTRICT="test"
  19. fi
  20. LICENSE="GPL-3"
  21. SLOT="0"
  22. IUSE="radioreference"
  23. DEPEND="${PYTHON_DEPS}
  24. dev-python/pyserial[${PYTHON_USEDEP}]
  25. dev-libs/libxml2[python]"
  26. RDEPEND="${DEPEND}
  27. dev-python/pygtk[${PYTHON_USEDEP}]
  28. radioreference? ( dev-python/suds[${PYTHON_USEDEP}] )"
  29. src_prepare() {
  30. sed -i -e "/share\/doc\/chirp/d" setup.py || die
  31. distutils-r1_src_prepare
  32. }
  33. python_test() {
  34. pushd tests > /dev/null
  35. "${PYTHON}" run_tests || die
  36. popd > /dev/null
  37. }