gnome-bluetooth-3.20.1.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 udev user
  5. DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
  6. HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
  7. LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
  8. SLOT="2/13" # subslot = libgnome-bluetooth soname version
  9. IUSE="debug +introspection"
  10. KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.38:2
  13. media-libs/libcanberra[gtk3]
  14. >=x11-libs/gtk+-3.12:3[introspection?]
  15. x11-libs/libnotify
  16. virtual/udev
  17. introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
  18. "
  19. RDEPEND="${COMMON_DEPEND}
  20. >=net-wireless/bluez-5
  21. "
  22. DEPEND="${COMMON_DEPEND}
  23. !net-wireless/bluez-gnome
  24. app-text/docbook-xml-dtd:4.1.2
  25. dev-libs/libxml2:2
  26. dev-util/gdbus-codegen
  27. >=dev-util/gtk-doc-am-1.9
  28. >=dev-util/intltool-0.40.0
  29. dev-util/itstool
  30. virtual/libudev
  31. virtual/pkgconfig
  32. x11-proto/xproto
  33. "
  34. # eautoreconf needs:
  35. # gnome-base/gnome-common
  36. pkg_setup() {
  37. enewgroup plugdev
  38. }
  39. src_prepare() {
  40. # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
  41. # https://bugzilla.gnome.org/show_bug.cgi?id=758096
  42. rm -v lib/bluetooth-client-glue.{c,h} || die
  43. gnome2_src_prepare
  44. }
  45. src_configure() {
  46. gnome2_src_configure \
  47. $(usex debug --enable-debug=yes ' ') \
  48. $(use_enable introspection) \
  49. --enable-documentation \
  50. --disable-desktop-update \
  51. --disable-icon-update \
  52. --disable-static
  53. }
  54. src_install() {
  55. gnome2_src_install
  56. udev_dorules "${FILESDIR}"/61-${PN}.rules
  57. }
  58. pkg_postinst() {
  59. gnome2_pkg_postinst
  60. if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
  61. elog "Don't forget to add yourself to the plugdev group "
  62. elog "if you want to be able to control bluetooth transmitter."
  63. fi
  64. }