gr-rftap-9999.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit cmake-utils python-single-r1
  6. DESCRIPTION="RFtap Module for GNU Radio"
  7. HOMEPAGE="https://github.com/rftap/gr-rftap"
  8. if [[ ${PV} == 9999* ]]; then
  9. inherit git-r3
  10. EGIT_REPO_URI="https://github.com/rftap/gr-rftap.git"
  11. KEYWORDS=""
  12. #else
  13. # SRC_URI=""
  14. # KEYWORDS=""
  15. fi
  16. LICENSE="GPL-3"
  17. SLOT="0/${PV}"
  18. RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
  19. dev-libs/boost:=[${PYTHON_USEDEP}]
  20. ${PYTHON_DEPS}"
  21. DEPEND="${RDEPEND}
  22. dev-lang/swig:0"
  23. #cppunit is listed in cmake, but only needed for tests and there are no tests
  24. # dev-util/cppunit"
  25. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  26. src_prepare() {
  27. #although cppunit is not used, it fails if it isn't there, fix it
  28. sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
  29. sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
  30. sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
  31. }
  32. src_configure() {
  33. mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
  34. cmake-utils_src_configure
  35. }