netgen-1.3.11.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils multilib
  5. DESCRIPTION="LVS tool (layout versus schematic comparison)"
  6. HOMEPAGE="http://www.opencircuitdesign.com/netgen/index.html"
  7. SRC_URI="http://www.opencircuitdesign.com/${PN}/archive/${P}.tgz"
  8. LICENSE="GPL-1"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="X"
  12. DEPEND="X? (
  13. dev-lang/tcl:0
  14. dev-lang/tk:0
  15. x11-libs/libX11 )"
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${PN}-1.3.10-tcl-bin-name.patch
  19. if $(use X) ; then
  20. cp -r "${S}" "${WORKDIR}"/with-x || die
  21. fi
  22. }
  23. src_configure() {
  24. cd scripts
  25. econf --without-x
  26. if $(use X) ; then
  27. cd "${WORKDIR}"/with-x/scripts || die
  28. econf --with-x
  29. fi
  30. }
  31. src_compile() {
  32. emake
  33. if $(use X) ; then
  34. cd "${WORKDIR}"/with-x || die
  35. emake
  36. fi
  37. }
  38. src_install() {
  39. dodir /usr/$(get_libdir)/${PN}
  40. emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
  41. if $(use X) ; then
  42. cd "${WORKDIR}"/with-x || die
  43. emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
  44. fi
  45. dodoc Changes README TO_DO
  46. }