netgen-1.4.52.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="LVS tool (layout versus schematic comparison)"
  6. HOMEPAGE="http://www.opencircuitdesign.com/netgen/index.html"
  7. SRC_URI="http://www.opencircuitdesign.com/${PN}/archive/${P}.tgz"
  8. LICENSE="GPL-1"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="X"
  12. DEPEND="X? (
  13. dev-lang/tcl:0
  14. dev-lang/tk:0
  15. x11-libs/libX11 )"
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${PN}-1.4.40-tcl-bin-name.patch
  19. if $(use X) ; then
  20. cp -r "${S}" "${WORKDIR}"/with-x || die
  21. fi
  22. }
  23. src_configure() {
  24. cd scripts
  25. econf --without-x
  26. if $(use X) ; then
  27. cd "${WORKDIR}"/with-x/scripts || die
  28. econf --with-x
  29. fi
  30. }
  31. src_compile() {
  32. emake
  33. if $(use X) ; then
  34. cd "${WORKDIR}"/with-x || die
  35. emake
  36. fi
  37. }
  38. src_install() {
  39. emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
  40. if $(use X) ; then
  41. cd "${WORKDIR}"/with-x || die
  42. emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
  43. fi
  44. dodoc Changes README TO_DO
  45. }