libtcd-2.2.6.ebuild 693 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_P=${PN}-${PV/_p/-r}
  6. DESCRIPTION="Library for reading and writing Tide Constituent Database (TCD) files"
  7. HOMEPAGE="http://www.flaterco.com/xtide/libtcd.html"
  8. SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
  9. LICENSE="public-domain"
  10. SLOT="0/1"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc static-libs"
  13. DEPEND=">=sci-geosciences/harmonics-dwf-free-20120302"
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}"/${P%_*}
  16. src_configure() {
  17. econf \
  18. $(use_enable static-libs static)
  19. }
  20. src_install() {
  21. default
  22. use static-libs || prune_libtool_files
  23. use doc && dohtml libtcd.html
  24. }