opencpn-plugin-objsearch-0.5.1-r1.ebuild 675 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WX_GTK_VER="3.0"
  5. inherit cmake-utils wxwidgets
  6. MY_PN="objsearch_pi"
  7. DESCRIPTION="Chart Object Search Plugin for OpenCPN"
  8. HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
  9. SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-2+"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND="
  15. >=sci-geosciences/opencpn-4.0.0
  16. <sci-geosciences/opencpn-4.2.0
  17. sys-devel/gettext
  18. x11-libs/wxGTK:${WX_GTK_VER}
  19. "
  20. DEPEND="${RDEPEND}"
  21. S="${WORKDIR}/${MY_PN}-${PV}"
  22. src_prepare() {
  23. need-wxwidgets unicode
  24. cmake-utils_src_prepare
  25. }