factmsieve-76-r1.ebuild 687 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
  7. HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
  8. SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. sci-mathematics/msieve
  16. sci-mathematics/ggnfs"
  17. DEPEND=""
  18. S="${WORKDIR}"
  19. PATCHES=( "${FILESDIR}/${P}.patch" )
  20. src_install() {
  21. python_fix_shebang ${PN}.py
  22. dobin ${PN}.py
  23. }