nestedsums-1.5.1.ebuild 836 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic
  5. DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
  6. HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
  7. IUSE="doc"
  8. SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. RDEPEND=">=sci-mathematics/ginac-1.7"
  13. DEPEND="${RDEPEND}
  14. doc? ( app-doc/doxygen )"
  15. src_configure() {
  16. append-cxxflags -std=c++11
  17. default
  18. }
  19. src_compile() {
  20. default
  21. if use doc; then
  22. doxygen Doxyfile || die "generating documentation failed"
  23. fi
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" install
  27. rm -f "${D}"usr/lib/*.la
  28. dodoc AUTHORS ChangeLog
  29. if use doc; then
  30. dohtml reference/html/*
  31. fi
  32. }