yoda-1.6.5.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit bash-completion-r1 python-single-r1
  6. DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
  7. HOMEPAGE="http://yoda.hepforge.org/"
  8. SRC_URI="http://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="python root static-libs"
  13. RDEPEND="
  14. dev-libs/boost:=
  15. python? ( ${PYTHON_DEPS} )
  16. root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
  17. DEPEND="${RDEPEND}
  18. python? ( dev-python/cython[${PYTHON_USEDEP}] )"
  19. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  20. S="${WORKDIR}/${P^^}"
  21. pkg_setup() {
  22. use python && python-single-r1_pkg_setup
  23. }
  24. src_configure() {
  25. econf \
  26. $(use_enable python pyext) \
  27. $(use_enable root) \
  28. $(use_enable static-libs static)
  29. }
  30. src_install() {
  31. default
  32. newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}
  33. rm "${ED%/}"/usr/share/YODA/yoda-completion || die
  34. }