xyscan-3.3.1-r1.ebuild 1015 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils versionator
  5. MY_PV=$(replace_version_separator 2 '')
  6. DESCRIPTION="Tool for extracting data points from graphs"
  7. HOMEPAGE="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
  8. SRC_URI="http://star.physics.yale.edu/~ullrich/${PN}DistributionPage/${MY_PV}/${PN}-${MY_PV}-src.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="l10n_fr"
  13. RDEPEND="dev-qt/qtcore:4
  14. dev-qt/qtgui:4"
  15. DEPEND="$RDEPEND"
  16. S="${WORKDIR}/${PN}"
  17. src_prepare() {
  18. default
  19. sed -i \
  20. -e "s:qApp->applicationDirPath() + \"/../docs\":\"${EPREFIX}/usr/share/doc/${PF}/html\":" \
  21. xyscanWindow.cpp || die "Failed to fix docs path"
  22. }
  23. src_configure() {
  24. eqmake4
  25. }
  26. src_install() {
  27. dobin xyscan
  28. HTML_DOCS=( docs/en/. )
  29. einstalldocs
  30. use l10n_fr && dodoc -r docs/fr
  31. newicon images/xyscanIcon.png xyscan.png
  32. make_desktop_entry xyscan "xyscan data point extractor"
  33. }