skel.ebuild 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # NOTE: The comments in this file are for instruction and documentation.
  4. # They're not meant to appear with your final, production ebuild. Please
  5. # remember to remove them before submitting or committing your ebuild. That
  6. # doesn't mean you can't add your own comments though.
  7. # The EAPI variable tells the ebuild format in use.
  8. # It is suggested that you use the latest EAPI approved by the Council.
  9. # The PMS contains specifications for all EAPIs. Eclasses will test for this
  10. # variable if they need to use features that are not universal in all EAPIs.
  11. EAPI=6
  12. # inherit lists eclasses to inherit functions from. For example, an ebuild
  13. # that needs the epatch function from eutils.eclass won't work without the
  14. # following line:
  15. inherit eutils
  16. #
  17. # eclasses tend to list descriptions of how to use their functions properly.
  18. # take a look at /usr/portage/eclass/ for more examples.
  19. # Short one-line description of this package.
  20. DESCRIPTION="This is a sample skeleton ebuild file"
  21. # Homepage, not used by Portage directly but handy for developer reference
  22. HOMEPAGE="https://foo.example.org/"
  23. # Point to any required sources; these will be automatically downloaded by
  24. # Portage.
  25. SRC_URI="ftp://foo.example.org/${P}.tar.gz"
  26. # License of the package. This must match the name of file(s) in
  27. # /usr/portage/licenses/. For complex license combination see the developer
  28. # docs on gentoo.org for details.
  29. LICENSE=""
  30. # The SLOT variable is used to tell Portage if it's OK to keep multiple
  31. # versions of the same package installed at the same time. For example,
  32. # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
  33. # with 1.2.2), it would be optimal to instruct Portage to not remove
  34. # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
  35. # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
  36. # emerge clean understands SLOTs, and will keep the most recent version
  37. # of each SLOT and remove everything else.
  38. # Note that normal applications should use SLOT="0" if possible, since
  39. # there should only be exactly one version installed at a time.
  40. # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
  41. SLOT="0"
  42. # Using KEYWORDS, we can record masking information *inside* an ebuild
  43. # instead of relying on an external package.mask file. Right now, you should
  44. # set the KEYWORDS variable for every ebuild so that it contains the names of
  45. # all the architectures with which the ebuild works. All of the official
  46. # architectures can be found in the arch.list file which is in
  47. # /usr/portage/profiles/. Usually you should just set this to "~x86". The ~
  48. # in front of the architecture indicates that the package is new and should be
  49. # considered unstable until testing proves its stability. So, if you've
  50. # confirmed that your ebuild works on x86 and ppc, you'd specify:
  51. # KEYWORDS="~x86 ~ppc"
  52. # Once packages go stable, the ~ prefix is removed.
  53. # For binary packages, use -* and then list the archs the bin package
  54. # exists for. If the package was for an x86 binary package, then
  55. # KEYWORDS would be set like this: KEYWORDS="-* x86"
  56. # DO NOT USE KEYWORDS="*". This is deprecated and only for backward
  57. # compatibility reasons.
  58. KEYWORDS="~x86"
  59. # Comprehensive list of any and all USE flags leveraged in the ebuild,
  60. # with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
  61. # "x86" and "alpha". Not needed if the ebuild doesn't use any USE flags.
  62. IUSE="gnome X"
  63. # A space delimited list of portage features to restrict. man 5 ebuild
  64. # for details. Usually not needed.
  65. #RESTRICT="strip"
  66. # Build-time dependencies, such as
  67. # ssl? ( >=dev-libs/openssl-0.9.6b )
  68. # >=dev-lang/perl-5.6.1-r1
  69. # It is advisable to use the >= syntax show above, to reflect what you
  70. # had installed on your system when you tested the package. Then
  71. # other users hopefully won't be caught without the right version of
  72. # a dependency.
  73. #DEPEND=""
  74. # Run-time dependencies. Must be defined to whatever this depends on to run.
  75. # The below is valid if the same run-time depends are required to compile.
  76. RDEPEND="${DEPEND}"
  77. # Source directory; the dir where the sources can be found (automatically
  78. # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
  79. # If you don't need to change it, leave the S= line out of the ebuild
  80. # to keep it tidy.
  81. #S=${WORKDIR}/${P}
  82. # The following src_configure function is implemented as default by portage, so
  83. # you only need to call it if you need a different behaviour.
  84. #src_configure() {
  85. # Most open-source packages use GNU autoconf for configuration.
  86. # The default, quickest (and preferred) way of running configure is:
  87. #econf
  88. #
  89. # You could use something similar to the following lines to
  90. # configure your package before compilation. The "|| die" portion
  91. # at the end will stop the build process if the command fails.
  92. # You should use this at the end of critical commands in the build
  93. # process. (Hint: Most commands are critical, that is, the build
  94. # process should abort if they aren't successful.)
  95. #./configure \
  96. # --host=${CHOST} \
  97. # --prefix=/usr \
  98. # --infodir=/usr/share/info \
  99. # --mandir=/usr/share/man || die
  100. # Note the use of --infodir and --mandir, above. This is to make
  101. # this package FHS 2.2-compliant. For more information, see
  102. # https://www.pathname.com/fhs/
  103. #}
  104. # The following src_compile function is implemented as default by portage, so
  105. # you only need to call it, if you need different behaviour.
  106. #src_compile() {
  107. # emake is a script that calls the standard GNU make with parallel
  108. # building options for speedier builds (especially on SMP systems).
  109. # Try emake first. It might not work for some packages, because
  110. # some makefiles have bugs related to parallelism, in these cases,
  111. # use emake -j1 to limit make to a single process. The -j1 is a
  112. # visual clue to others that the makefiles have bugs that have been
  113. # worked around.
  114. #emake
  115. #}
  116. # The following src_install function is implemented as default by portage, so
  117. # you only need to call it, if you need different behaviour.
  118. #src_install() {
  119. # You must *personally verify* that this trick doesn't install
  120. # anything outside of DESTDIR; do this by reading and
  121. # understanding the install part of the Makefiles.
  122. # This is the preferred way to install.
  123. #emake DESTDIR="${D}" install
  124. # When you hit a failure with emake, do not just use make. It is
  125. # better to fix the Makefiles to allow proper parallelization.
  126. # If you fail with that, use "emake -j1", it's still better than make.
  127. # For Makefiles that don't make proper use of DESTDIR, setting
  128. # prefix is often an alternative. However if you do this, then
  129. # you also need to specify mandir and infodir, since they were
  130. # passed to ./configure as absolute paths (overriding the prefix
  131. # setting).
  132. #emake \
  133. # prefix="${D}"/usr \
  134. # mandir="${D}"/usr/share/man \
  135. # infodir="${D}"/usr/share/info \
  136. # libdir="${D}"/usr/$(get_libdir) \
  137. # install
  138. # Again, verify the Makefiles! We don't want anything falling
  139. # outside of ${D}.
  140. #}