libnss-cache-0.10.2.ebuild 878 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=3
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="libnss-cache is a library that serves nss lookups"
  6. HOMEPAGE="https://github.com/google/nsscache"
  7. SRC_URI="https://nsscache.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="multilib"
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${PN}-0.10.1-make.patch
  14. epatch "${FILESDIR}"/${PN}-0.10-fix-shadow-test.patch
  15. }
  16. src_compile() {
  17. emake CC="$(tc-getCC)" nss_cache || die
  18. if use multilib && has_multilib_profile; then
  19. emake CC="$(tc-getCC)" nss_cache32 || die
  20. fi
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die
  24. if use multilib && has_multilib_profile; then
  25. emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install32 || die
  26. fi
  27. }