automake-1.12.6.ebuild 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:4}"
  11. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}
  18. sys-apps/help2man"
  19. src_prepare() {
  20. export WANT_AUTOCONF=2.5
  21. sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
  22. }
  23. src_configure() {
  24. econf --docdir="\$(datarootdir)/doc/${PF}"
  25. }
  26. # slot the info pages. do this w/out munging the source so we don't have
  27. # to depend on texinfo to regen things. #464146 (among others)
  28. slot_info_pages() {
  29. pushd "${ED}"/usr/share/info >/dev/null
  30. rm -f dir
  31. # Rewrite all the references to other pages.
  32. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  33. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  34. local p pages=( *.info ) args=()
  35. for p in "${pages[@]/%.info}" ; do
  36. args+=(
  37. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  38. -e "s:(${p}):(${p}-${SLOT}):g"
  39. )
  40. done
  41. sed -i "${args[@]}" * || die
  42. # Rewrite all the file references, and rename them in the process.
  43. local f d
  44. for f in * ; do
  45. d=${f/.info/-${SLOT}.info}
  46. mv "${f}" "${d}" || die
  47. sed -i -e "s:${f}:${d}:g" * || die
  48. done
  49. popd >/dev/null
  50. }
  51. src_install() {
  52. default
  53. slot_info_pages
  54. rm "${ED}"/usr/share/aclocal/README || die
  55. rmdir "${ED}"/usr/share/aclocal || die
  56. rm \
  57. "${ED}"/usr/bin/{aclocal,automake} \
  58. "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
  59. # remove all config.guess and config.sub files replacing them
  60. # w/a symlink to a specific gnuconfig version
  61. local x
  62. for x in guess sub ; do
  63. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  64. done
  65. }