ucpp-1.3.4.ebuild 550 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
  6. HOMEPAGE="https://code.google.com/p/ucpp/"
  7. SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"
  11. IUSE="static-libs"
  12. src_configure() {
  13. econf \
  14. --disable-werror \
  15. $(use_enable static-libs static)
  16. }
  17. src_install() {
  18. default
  19. prune_libtool_files --all
  20. }