intel-microcode-20150121.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. # Find updates by searching and clicking the first link (hopefully it's the one):
  6. # http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
  7. NUM="24661"
  8. DESCRIPTION="Intel IA32 microcode update data"
  9. HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
  10. SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
  11. LICENSE="intel-ucode"
  12. SLOT="0"
  13. KEYWORDS="-* amd64 x86"
  14. IUSE=""
  15. RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
  16. S=${WORKDIR}
  17. src_unpack() {
  18. default
  19. cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
  20. }
  21. src_compile() {
  22. tc-env_build emake intel-microcode2ucode
  23. ./intel-microcode2ucode microcode.dat || die
  24. }
  25. src_install() {
  26. insinto /lib/firmware
  27. doins -r microcode.dat intel-ucode
  28. }
  29. pkg_postinst() {
  30. elog "The microcode available for Intel CPUs has been updated. You'll need"
  31. elog "to reload the code into your processor. If you're using the init.d:"
  32. elog "/etc/init.d/microcode_ctl restart"
  33. }