vgabios-0.6c-r1.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. # Can't really call them backports when they're fixes that upstream
  5. # won't carry
  6. FIXES=2
  7. inherit eutils
  8. DESCRIPTION="VGA BIOS implementation"
  9. HOMEPAGE="http://www.nongnu.org/vgabios/"
  10. SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz
  11. https://dev.gentoo.org/~cardoe/distfiles/${P}-bins.tar.xz
  12. https://dev.gentoo.org/~cardoe/distfiles/${P}-fixes-${FIXES}.tar.bz2"
  13. LICENSE="LGPL-2.1"
  14. SLOT="0"
  15. KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-fbsd"
  16. IUSE="debug"
  17. DEPEND="amd64? ( sys-devel/dev86 )
  18. x86? ( sys-devel/dev86 )"
  19. RDEPEND=""
  20. src_prepare() {
  21. [[ -n ${FIXES} ]] && \
  22. EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
  23. epatch
  24. }
  25. src_compile() {
  26. if use amd64 || use x86 ; then
  27. emake clean # Necessary to clean up the pre-built pieces
  28. emake biossums
  29. emake
  30. fi
  31. }
  32. src_install() {
  33. insinto /usr/share/vgabios
  34. if use amd64 || use x86 ; then
  35. # Stock VGABIOS
  36. newins VGABIOS-lgpl-latest.bin vgabios.bin
  37. use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
  38. # Cirrus
  39. newins VGABIOS-lgpl-latest.cirrus.bin vgabios-cirrus.bin
  40. use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
  41. vgabios-cirrus.debug.bin
  42. # QXL
  43. newins VGABIOS-lgpl-latest.qxl.bin vgabios-qxl.bin
  44. use debug && newins VGABIOS-lgpl-latest.qxl.debug.bin \
  45. vgabios-qxl.debug.bin
  46. # Standard VGA
  47. newins VGABIOS-lgpl-latest.stdvga.bin vgabios-stdvga.bin
  48. use debug && newins VGABIOS-lgpl-latest.stdvga.debug.bin \
  49. vgabios-stdvga.debug.bin
  50. # VMWare
  51. newins VGABIOS-lgpl-latest.vmware.bin vgabios-vmware.bin
  52. use debug && newins VGABIOS-lgpl-latest.vmware.debug.bin \
  53. vgabios-vmware.debug.bin
  54. else
  55. doins bins/*
  56. fi
  57. }