vgabios-0.7a-r1.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. # Can't really call them backports when they're fixes that upstream
  5. # won't carry
  6. FIXES=1
  7. inherit eutils
  8. DESCRIPTION="VGA BIOS implementation"
  9. HOMEPAGE="http://www.nongnu.org/vgabios/"
  10. SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz
  11. https://dev.gentoo.org/~cardoe/distfiles/${P}-fixes-${FIXES}.tar.bz2"
  12. LICENSE="LGPL-2.1"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  15. IUSE="binary debug"
  16. DEPEND="!binary? ( sys-devel/dev86 )"
  17. RDEPEND=""
  18. src_prepare() {
  19. [[ -n ${FIXES} ]] && \
  20. EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
  21. epatch
  22. epatch_user
  23. }
  24. src_compile() {
  25. if ! use binary ; then
  26. emake clean # Necessary to clean up the pre-built pieces
  27. emake biossums
  28. emake
  29. fi
  30. }
  31. src_install() {
  32. insinto /usr/share/vgabios
  33. # Stock VGABIOS
  34. newins VGABIOS-lgpl-latest.bin vgabios.bin
  35. use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
  36. # Cirrus
  37. newins VGABIOS-lgpl-latest.cirrus.bin vgabios-cirrus.bin
  38. use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
  39. vgabios-cirrus.debug.bin
  40. if ! use binary ; then
  41. # QXL
  42. newins VGABIOS-lgpl-latest.qxl.bin vgabios-qxl.bin
  43. use debug && newins VGABIOS-lgpl-latest.qxl.debug.bin \
  44. vgabios-qxl.debug.bin
  45. # Standard VGA
  46. newins VGABIOS-lgpl-latest.stdvga.bin vgabios-stdvga.bin
  47. use debug && newins VGABIOS-lgpl-latest.stdvga.debug.bin \
  48. vgabios-stdvga.debug.bin
  49. # VMWare
  50. newins VGABIOS-lgpl-latest.vmware.bin vgabios-vmware.bin
  51. use debug && newins VGABIOS-lgpl-latest.vmware.debug.bin \
  52. vgabios-vmware.debug.bin
  53. else
  54. ewarn "USE=binary only includes default & cirrus bios builds"
  55. fi
  56. }