openvz-sources-2.6.32.108.8.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit versionator
  5. OVZ_KV="$(get_version_component_range 4).$(get_version_component_range 5)"
  6. CKV=$(get_version_component_range 1-3)
  7. OKV=${OKV:-${CKV}}
  8. EXTRAVERSION=-${PN/-*}-${OVZ_KV}
  9. ETYPE="sources"
  10. KV_FULL=${CKV}${EXTRAVERSION}
  11. if [[ ${PR} != "r0" ]]; then
  12. KV_FULL+=-${PR}
  13. EXTRAVERSION+=-${PR}
  14. fi
  15. S=${WORKDIR}/linux-${KV_FULL}
  16. # ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} should succeed.
  17. KV_MAJOR=$(get_version_component_range 1 ${OKV})
  18. KV_MINOR=$(get_version_component_range 2 ${OKV})
  19. KV_PATCH=$(get_version_component_range 3 ${OKV})
  20. KERNEL_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.xz"
  21. K_SECURITY_UNSUPPORTED="1"
  22. K_DEBLOB_AVAILABLE=0
  23. inherit kernel-2
  24. #detect_version
  25. KEYWORDS="amd64 ~ppc64 ~sparc x86"
  26. IUSE=""
  27. DESCRIPTION="Kernel sources with OpenVZ patchset"
  28. HOMEPAGE="http://www.openvz.org"
  29. SRC_URI="${KERNEL_URI} ${ARCH_URI}
  30. http://download.openvz.org/kernel/branches/rhel6-${CKV}/042stab${OVZ_KV}/patches/patch-042stab${OVZ_KV}-combined.gz"
  31. UNIPATCH_STRICTORDER=1
  32. UNIPATCH_LIST="${DISTDIR}/patch-042stab${OVZ_KV}-combined.gz"
  33. K_EXTRAEINFO="This openvz kernel uses RHEL6 patchset instead of vanilla kernel.
  34. This patchset considered to be more stable and security supported by upstream,
  35. but for us RHEL6 patchset is very fragile and fails to build in many
  36. configurations so if you have problems use config files from openvz team
  37. http://wiki.openvz.org/Download/kernel/rhel6/042stab${OVZ_KV}"