pf-sources-3.11.4.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit readme.gentoo versionator
  5. COMPRESSTYPE=".bz2"
  6. K_USEPV="yes"
  7. UNIPATCH_STRICTORDER="yes"
  8. K_SECURITY_UNSUPPORTED="1"
  9. CKV="$(get_version_component_range 1-2)"
  10. ETYPE="sources"
  11. inherit kernel-2
  12. detect_version
  13. K_NOSETEXTRAVERSION="don't_set_it"
  14. DESCRIPTION="Linux kernel fork with new features (-ck patchset (BFS), BFQ, TuxOnIce and UKSM)"
  15. HOMEPAGE="http://pf.natalenko.name/"
  16. PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
  17. PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
  18. EXPERIMENTAL_PATCHES=(
  19. # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
  20. # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
  21. )
  22. EXPERIMENTAL_URI="
  23. experimental? (
  24. ${EXPERIMENTAL_PATCHES[@]}
  25. )
  26. "
  27. SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
  28. KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
  29. IUSE="" # experimental
  30. KV_FULL="${PVR}-pf"
  31. S="${WORKDIR}"/linux-"${KV_FULL}"
  32. DISABLE_AUTOFORMATTING="yes"
  33. DOC_CONTENTS="
  34. ${P} has the following optional runtime dependencies:
  35. - sys-apps/tuxonice-userui: provides minimal userspace progress
  36. information related to suspending and resuming process.
  37. - sys-power/hibernate-script or sys-power/pm-utils: runtime utilities
  38. for hibernating and suspending your computer."
  39. pkg_setup(){
  40. ewarn
  41. ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
  42. ewarn "If you need support, please contact the pf developers directly."
  43. ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
  44. ewarn "the ebuilds. Thank you."
  45. ewarn
  46. kernel-2_pkg_setup
  47. }
  48. src_prepare(){
  49. epatch "${DISTDIR}"/"${PF_FILE}"
  50. }
  51. src_install() {
  52. kernel-2_src_install
  53. readme.gentoo_create_doc
  54. }
  55. pkg_postinst() {
  56. kernel-2_pkg_postinst
  57. readme.gentoo_print_elog
  58. }
  59. K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
  60. see: ${HOMEPAGE}."