pf-sources-3.17_p4.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit readme.gentoo versionator
  5. COMPRESSTYPE=".xz"
  6. K_USEPV="yes"
  7. UNIPATCH_STRICTORDER="yes"
  8. K_SECURITY_UNSUPPORTED="1"
  9. CKV="$(get_version_component_range 1-2)"
  10. ETYPE="sources"
  11. inherit kernel-2
  12. detect_version
  13. K_NOSETEXTRAVERSION="don't_set_it"
  14. DESCRIPTION="Linux kernel fork with new features (-ck patchset (BFS), BFQ, TuxOnIce and UKSM)"
  15. HOMEPAGE="http://pf.natalenko.name/"
  16. PF_VERS="1"
  17. PF_FILE="patch-${PV/_p*/}-pf${PV/*_p/}${COMPRESSTYPE}"
  18. PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
  19. SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
  20. KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
  21. IUSE=""
  22. KV_FULL="${PVR}-pf"
  23. S="${WORKDIR}"/linux-"${KV_FULL}"
  24. DISABLE_AUTOFORMATTING="yes"
  25. DOC_CONTENTS="
  26. ${P} has the following optional runtime dependencies:
  27. - sys-apps/tuxonice-userui: provides minimal userspace progress
  28. information related to suspending and resuming process.
  29. - sys-power/hibernate-script or sys-power/pm-utils: runtime utilities
  30. for hibernating and suspending your computer."
  31. pkg_setup(){
  32. ewarn
  33. ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
  34. ewarn "If you need support, please contact the pf developers directly."
  35. ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
  36. ewarn "the ebuilds. Thank you."
  37. ewarn
  38. kernel-2_pkg_setup
  39. }
  40. src_prepare(){
  41. epatch "${DISTDIR}"/"${PF_FILE}"
  42. }
  43. src_install() {
  44. kernel-2_src_install
  45. readme.gentoo_create_doc
  46. }
  47. pkg_postinst() {
  48. kernel-2_pkg_postinst
  49. readme.gentoo_print_elog
  50. }
  51. K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
  52. see: ${HOMEPAGE}."