pf-sources-3.4.6.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit versionator
  5. COMPRESSTYPE=".bz2"
  6. K_USEPV="yes"
  7. UNIPATCH_STRICTORDER="yes"
  8. K_SECURITY_UNSUPPORTED="1"
  9. CKV="$(get_version_component_range 1-2)"
  10. ETYPE="sources"
  11. inherit kernel-2
  12. detect_version
  13. K_NOSETEXTRAVERSION="don't_set_it"
  14. DESCRIPTION="Linux kernel fork with new features (-ck patchset (BFS), BFQ, TuxOnIce and UKSM)"
  15. HOMEPAGE="http://pf.natalenko.name/"
  16. PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
  17. PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
  18. EXPERIMENTAL_PATCHES=(
  19. # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
  20. # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
  21. )
  22. EXPERIMENTAL_URI="
  23. experimental? (
  24. ${EXPERIMENTAL_PATCHES[@]}
  25. )
  26. "
  27. SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
  28. KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
  29. IUSE="" # experimental
  30. KV_FULL="${PVR}-pf"
  31. S="${WORKDIR}"/linux-"${KV_FULL}"
  32. pkg_setup(){
  33. ewarn
  34. ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
  35. ewarn "If you need support, please contact the pf developers directly."
  36. ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
  37. ewarn "the ebuilds. Thank you."
  38. ewarn
  39. kernel-2_pkg_setup
  40. }
  41. src_prepare(){
  42. epatch "${DISTDIR}"/"${PF_FILE}"
  43. }
  44. pkg_postinst() {
  45. kernel-2_pkg_postinst
  46. elog
  47. elog "${P} has the following optional runtime dependencies:"
  48. elog " sys-apps/tuxonice-userui"
  49. elog " provides minimal userspace progress information related to"
  50. elog " suspending and resuming process"
  51. elog " sys-power/hibernate-script or sys-power/pm-utils"
  52. elog " runtime utilites for hibernating and suspending your computer"
  53. elog
  54. }
  55. K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
  56. see: ${HOMEPAGE}."