pf-sources-4.0_p6.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit readme.gentoo toolchain-funcs versionator
  5. COMPRESSTYPE=".xz"
  6. K_USEPV="yes"
  7. UNIPATCH_STRICTORDER="yes"
  8. K_SECURITY_UNSUPPORTED="1"
  9. CKV="$(get_version_component_range 1-2)"
  10. ETYPE="sources"
  11. inherit kernel-2
  12. detect_version
  13. K_NOSETEXTRAVERSION="don't_set_it"
  14. DESCRIPTION="Linux kernel fork with new features (-ck patchset (BFS), BFQ, TuxOnIce and UKSM)"
  15. HOMEPAGE="http://pf.natalenko.name/"
  16. PF_VERS="1"
  17. PF_FILE="patch-${PV/_p*/}-pf${PV/*_p/}${COMPRESSTYPE}"
  18. PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
  19. SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
  20. KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
  21. IUSE=""
  22. KV_FULL="${PVR}-pf"
  23. S="${WORKDIR}"/linux-"${KV_FULL}"
  24. DISABLE_AUTOFORMATTING="yes"
  25. DOC_CONTENTS="
  26. ${P} has the following optional runtime dependencies:
  27. - sys-apps/tuxonice-userui: provides minimal userspace progress
  28. information related to suspending and resuming process.
  29. - sys-power/hibernate-script or sys-power/pm-utils: runtime utilities
  30. for hibernating and suspending your computer."
  31. pkg_pretend() {
  32. # 547868
  33. if [[ $(gcc-version) < 4.9 ]]; then
  34. eerror ""
  35. eerror "${P} needs an active GCC 4.9+ compiler"
  36. eerror ""
  37. die "${P} needs an active sys-devel/gcc >= 4.9"
  38. fi
  39. }
  40. pkg_setup(){
  41. ewarn
  42. ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
  43. ewarn "If you need support, please contact the pf developers directly."
  44. ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
  45. ewarn "the ebuilds. Thank you."
  46. ewarn
  47. kernel-2_pkg_setup
  48. }
  49. src_prepare(){
  50. epatch "${DISTDIR}"/"${PF_FILE}"
  51. }
  52. src_install() {
  53. kernel-2_src_install
  54. readme.gentoo_create_doc
  55. }
  56. pkg_postinst() {
  57. kernel-2_pkg_postinst
  58. readme.gentoo_print_elog
  59. }
  60. K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
  61. see: ${HOMEPAGE}."