rt-sources-4.1.38_p45.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. ETYPE="sources"
  5. KEYWORDS="~amd64"
  6. HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
  7. inherit versionator
  8. CKV="$(get_version_component_range 1-3)"
  9. K_SECURITY_UNSUPPORTED="1"
  10. K_DEBLOB_AVAILABLE="1"
  11. RT_PATCHSET="${PV/*_p}"
  12. inherit kernel-2
  13. detect_version
  14. K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
  15. RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
  16. RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
  17. mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
  18. DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
  19. SRC_URI="${KERNEL_URI} ${RT_URI}"
  20. KV_FULL="${PVR/_p/-rt}"
  21. S="${WORKDIR}/linux-${KV_FULL}"
  22. UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
  23. UNIPATCH_STRICTORDER="yes"
  24. pkg_postinst() {
  25. ewarn
  26. ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
  27. ewarn "If you need support, please contact the RT project developers directly."
  28. ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
  29. ewarn "the ebuilds."
  30. ewarn
  31. }
  32. K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
  33. ${HOMEPAGE}."