123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal toolchain-funcs
- #Number of official patches
- #PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
- PATCHNO=${PV/*.*.*_p}
- if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
- else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
- fi
- S="${WORKDIR}/${MY_P}/build_unix"
- DESCRIPTION="Oracle Berkeley DB"
- HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
- SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
- for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
- done
- LICENSE="Sleepycat"
- SLOT="4.8"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
- IUSE="doc java cxx tcl test"
- REQUIRED_USE="test? ( tcl )"
- # the entire testsuite needs the TCL functionality
- DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jdk-1.5 )
- >=sys-devel/binutils-2.16.1"
- RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jre-1.5 )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140508-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
- src_prepare() {
- cd "${WORKDIR}"/"${MY_P}" || die
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
- epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
- epatch "${FILESDIR}"/${PN}-4.8.30-rename-atomic-compare-exchange.patch
- # use the includes from the prefix
- epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
- sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE \
- || die
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S}"/../dist/Makefile.in || die
- cd "${S}"/../dist || die
- rm -f aclocal/libtool.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac || die
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4 || die
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- sed -i \
- -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
- -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
- -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
- -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
- -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
- -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure || die
- }
- multilib_src_configure() {
- local myconf=()
- tc-ld-disable-gold #470634
- # compilation with -O0 fails on amd64, see bug #171231
- if [[ ${ABI} == amd64 ]]; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
- # use `set` here since the java opts will contain whitespace
- if multilib_is_native_abi && use java ; then
- myconf+=(
- --with-java-prefix="${JAVA_HOME}"
- --with-javac-flags="$(java-pkg_javac-args)"
- )
- fi
- # Bug #270851: test needs TCL support
- if use tcl || use test ; then
- myconf+=(
- --enable-tcl
- --with-tcl="${EPREFIX}/usr/$(get_libdir)"
- )
- else
- myconf+=(--disable-tcl )
- fi
- ECONF_SOURCE="${S}"/../dist \
- STRIP="true" \
- econf \
- --enable-compat185 \
- --enable-o_direct \
- --without-uniquename \
- $([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
- $([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
- $(use_enable cxx) \
- $(use_enable cxx stl) \
- $(multilib_native_use_enable java) \
- "${myconf[@]}" \
- $(use_enable test)
- }
- multilib_src_test() {
- multilib_is_native_abi || return
- S=${BUILD_DIR} db_src_test
- }
- multilib_src_install() {
- emake install DESTDIR="${D}"
- db_src_install_headerslot
- db_src_install_usrlibcleanup
- if multilib_is_native_abi && use java; then
- java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
- rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
- fi
- }
- multilib_src_install_all() {
- db_src_install_usrbinslot
- db_src_install_doc
- dodir /usr/sbin
- # This file is not always built, and no longer exists as of db-4.8
- if [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] ; then
- mv "${ED}"/usr/bin/berkeley_db_svc \
- "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
- fi
- }
- pkg_postinst() {
- multilib_foreach_abi db_fix_so
- }
- pkg_postrm() {
- multilib_foreach_abi db_fix_so
- }
|