numad-0.5-r1.ebuild 938 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit linux-info toolchain-funcs
  5. if [[ ${PV} = *9999* ]]; then
  6. inherit git-2
  7. EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
  8. KEYWORDS="~amd64 -arm -s390 x86"
  9. else
  10. SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
  11. KEYWORDS="amd64 -arm -s390 x86"
  12. S="${WORKDIR}/${PN}-334278f"
  13. fi
  14. DESCRIPTION="The NUMA daemon that manages application locality"
  15. HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
  16. LICENSE="LGPL-2.1"
  17. SLOT="0"
  18. IUSE=""
  19. CONFIG_CHECK="~NUMA ~CPUSETS"
  20. src_prepare() {
  21. EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
  22. epatch
  23. tc-export CC
  24. }
  25. src_configure() {
  26. :
  27. }
  28. src_compile() {
  29. emake CFLAGS="${CFLAGS} -std=gnu99"
  30. }
  31. src_install() {
  32. emake prefix="${ED}/usr" install
  33. }