numad-9999.ebuild 734 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit linux-info toolchain-funcs eutils
  5. if [[ ${PV} == "9999" ]]; then
  6. EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
  7. inherit git-2
  8. else
  9. SRC_URI=""
  10. KEYWORDS="~amd64 ~x86 -arm -s390"
  11. fi
  12. DESCRIPTION="The NUMA daemon that manages application locality"
  13. HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
  14. LICENSE="LGPL-2.1"
  15. SLOT="0"
  16. IUSE=""
  17. CONFIG_CHECK="~NUMA ~CPUSETS"
  18. src_prepare() {
  19. epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
  20. tc-export CC
  21. }
  22. src_configure() {
  23. :
  24. }
  25. src_compile() {
  26. emake CFLAGS="${CFLAGS} -std=gnu99"
  27. }
  28. src_install() {
  29. emake prefix="${ED}/usr" install
  30. }