mod_fastcgi_handler-0.6.ebuild 690 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. GITHUB_AUTHOR="hollow"
  5. GITHUB_PROJECT="mod_fastcgi_handler"
  6. GITHUB_COMMIT="c5e075b"
  7. inherit apache-module
  8. DESCRIPTION="A simple FastCGI handler module"
  9. HOMEPAGE="https://github.com/hollow/mod_fastcgi_handler"
  10. SRC_URI="https://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. DEPEND=""
  16. RDEPEND=""
  17. S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}
  18. APACHE2_MOD_CONF="20_${PN}"
  19. APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
  20. APXS2_ARGS="-o ${PN}.so -c *.c"
  21. need_apache2