mod_nss-1.0.12-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools apache-module eutils
  5. DESCRIPTION="SSL/TLS module for the Apache HTTP server"
  6. HOMEPAGE="https://fedorahosted.org/mod_nss/"
  7. SRC_URI="https://fedorahosted.org/released/mod_nss/${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="+ecc"
  12. DEPEND="
  13. >=dev-libs/nspr-4.6.4
  14. >=dev-libs/nss-3.11.4
  15. sys-apps/sed
  16. virtual/pkgconfig
  17. "
  18. RDEPEND="
  19. >=dev-libs/nspr-4.6.4
  20. >=dev-libs/nss-3.11.4
  21. net-dns/bind-tools
  22. "
  23. APACHE2_MOD_CONF="47_${PN}"
  24. APACHE2_MOD_DEFINE="NSS"
  25. DOCFILES="NOTICE README"
  26. need_apache2
  27. src_prepare() {
  28. default
  29. # setup proper exec name
  30. sed -i -e 's/certutil/nsscertutil/' gencert.in || die "sed failed"
  31. eautoreconf
  32. }
  33. src_configure() {
  34. econf $(use_enable ecc) --with-apxs=${APXS}
  35. }
  36. src_compile() {
  37. # default src_compile fails:
  38. # In file included from mod_nss.c:16:0:
  39. # mod_nss.h:51:18: fatal error: nspr.h: No such file or directory
  40. emake
  41. }
  42. src_install() {
  43. # override broken build system
  44. mv .libs/libmodnss.so .libs/"${PN}".so || die "cannot move lib"
  45. dosbin gencert nss_pcache
  46. dodoc docs/mod_nss.html
  47. newbin migrate.pl nss_migrate
  48. dodir /etc/apache2/nss
  49. apache-module_src_install
  50. }