mod_qos-11.12.ebuild 1015 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools apache-module
  5. DESCRIPTION="A QOS module for the apache webserver"
  6. HOMEPAGE="http://mod-qos.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. dev-libs/libpcre
  14. dev-libs/openssl:0
  15. media-libs/libpng:0=
  16. sys-libs/zlib
  17. "
  18. DEPEND="${DEPEND}"
  19. APXS2_S="${S}/apache2"
  20. APACHE2_MOD_CONF="10_${PN}"
  21. APACHE2_MOD_DEFINE="QOS"
  22. DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
  23. need_apache2
  24. src_prepare() {
  25. cd "${S}/tools" && eautoreconf
  26. }
  27. src_configure() {
  28. cd "${S}/tools" && econf
  29. }
  30. src_compile() {
  31. apache-module_src_compile
  32. emake -C "${S}/tools"
  33. }
  34. src_install() {
  35. einfo "Installing Apache module ..."
  36. cd "${S}/tools"
  37. apache-module_src_install
  38. einfo "Installing module utilities ..."
  39. emake -C "${S}/tools" install DESTDIR="${D}"
  40. # installing html documentation
  41. dohtml -r -x *.txt "${S}/doc/"
  42. }