mod_vhost_ldap-2.4.0-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit apache-module
  5. DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
  6. HOMEPAGE="http://modvhostldap.alioth.debian.org/"
  7. SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. APACHE2_MOD_CONF="99_${PN}"
  13. APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
  14. DOCFILES="AUTHORS ChangeLog README"
  15. # We need apr-util[ldap] and apache to build, but the ldap module for
  16. # apache is only needed when we try to run the thing.
  17. DEPEND="dev-libs/apr-util[ldap]"
  18. RDEPEND="=www-servers/apache-2.4*[ldap]"
  19. need_apache2_4
  20. src_prepare() {
  21. default
  22. sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c" || \
  23. die "failed to sed version string"
  24. }
  25. src_install() {
  26. apache-module_src_install
  27. insinto /etc/openldap/schema
  28. doins mod_vhost_ldap.schema
  29. }
  30. pkg_postinst() {
  31. apache-module_pkg_postinst
  32. einfo
  33. einfo "Your LDAP server needs to include mod_vhost_ldap.schema and should"
  34. einfo "also maintain indices on apacheServerName and apacheServerAlias."
  35. einfo
  36. }